aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commit6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e (patch)
tree30cacdb892969714d2a079f391ba6786b7c36489 /target/linux/rdc/Makefile
parent9647361f814667b536160d416666bd25ab4b82fa (diff)
downloadmaster-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.gz
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.bz2
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc/Makefile')
-rw-r--r--target/linux/rdc/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/rdc/Makefile b/target/linux/rdc/Makefile
index 5af5e85c6e..ac49adeb97 100644
--- a/target/linux/rdc/Makefile
+++ b/target/linux/rdc/Makefile
@@ -13,15 +13,15 @@ FEATURES:=squashfs jffs2 broken
LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
+
define Target/Description
Build firmware images for RDC321x based routers
(e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)
endef
-include $(INCLUDE_DIR)/kernel-build.mk
-
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- define Kernel/SetInitramfs
+ define Kernel/SetInitramfs
echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
$(RM) $(TARGET_DIR)/sbin/init
ln -s /etc/preinit $(TARGET_DIR)/sbin/init
@@ -29,10 +29,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init
mv $(TARGET_DIR)/init $(TARGET_DIR)/linuxrc
sed -i 's,eth0,eth1,g' $(TARGET_DIR)/etc/config/network
- endef
+ endef
endif
# include the profiles
-include profiles/*.mk
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))