aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/Makefile
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit593b560d9371a5203c60e7e3161d86a65c2b9bb1 (patch)
treef560743479e4aef6d9013643b9b26923cd248bc1 /target/linux/rdc-2.6/Makefile
parent6206e865143b2b17f2bdb9e9584e3259b7edc4f2 (diff)
downloadmaster-187ad058-593b560d9371a5203c60e7e3161d86a65c2b9bb1.tar.gz
master-187ad058-593b560d9371a5203c60e7e3161d86a65c2b9bb1.tar.bz2
master-187ad058-593b560d9371a5203c60e7e3161d86a65c2b9bb1.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc-2.6/Makefile')
-rw-r--r--target/linux/rdc-2.6/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
index f1f751eee6..306734b273 100644
--- a/target/linux/rdc-2.6/Makefile
+++ b/target/linux/rdc-2.6/Makefile
@@ -18,10 +18,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
-define Profile/Ralink
- NAME:=Ralink WiFi (default)
- PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))