aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-07-07 08:51:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-07-07 08:51:55 +0000
commitae1fd5f9d7f59983113b126ff52141da464ea109 (patch)
treeb76677bf3ae263ddc7e86cac229734c407b242cc /target/linux/rb532
parent8869e6ed865d729cc3950f90fa833845ae32b7ae (diff)
downloadmaster-187ad058-ae1fd5f9d7f59983113b126ff52141da464ea109.tar.gz
master-187ad058-ae1fd5f9d7f59983113b126ff52141da464ea109.tar.bz2
master-187ad058-ae1fd5f9d7f59983113b126ff52141da464ea109.zip
rb532: really fix squashfs images
The previous attempt (r40717) to fix squashfx made the system bootable but overlayfs remained broken. This enables block2mtd again using the right partition number and naming and adds MTD_ROOTFS_SPLIT option. However onboard rootfs partition name had to be renamed to place overlay on CF instead of onboard NAND. Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41541 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532')
-rw-r--r--target/linux/rb532/config-3.102
-rw-r--r--target/linux/rb532/image/Makefile2
-rw-r--r--target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch11
3 files changed, 13 insertions, 2 deletions
diff --git a/target/linux/rb532/config-3.10 b/target/linux/rb532/config-3.10
index 3e7c9e4f40..5e7dd3d1df 100644
--- a/target/linux/rb532/config-3.10
+++ b/target/linux/rb532/config-3.10
@@ -103,7 +103,7 @@ CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_NAND_PLATFORM=y
CONFIG_MTD_PHYSMAP=y
# CONFIG_MTD_ROOTFS_ROOT_DEV is not set
-# CONFIG_MTD_ROOTFS_SPLIT is not set
+CONFIG_MTD_ROOTFS_SPLIT=y
# CONFIG_MTD_SM_COMMON is not set
# CONFIG_MTD_SPLIT is not set
CONFIG_NEED_DMA_MAP_STATE=y
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index 65ef919fa9..e33fbab208 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -56,7 +56,7 @@ root=/dev/sda2 rootfstype=ext4
endef
define Image/cmdline/squashfs
-root=/dev/sda2 rootfstype=squashfs
+block2mtd.block2mtd=/dev/sda2,65536,rootfs root=/dev/mtdblock2 rootfstype=squashfs
endef
define Image/cmdline/yaffs2
diff --git a/target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch b/target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch
new file mode 100644
index 0000000000..e3f6c4113e
--- /dev/null
+++ b/target/linux/rb532/patches-3.10/004-rb532_partition_info-rename-rootfs-to-rootfs_onboard.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/rb532/devices.c 2014-07-07 01:05:10.000000000 +0300
++++ b/arch/mips/rb532/devices.c 2014-07-07 01:05:27.268505016 +0300
+@@ -202,7 +202,7 @@ static struct mtd_partition rb532_partit
+ .offset = 0,
+ .size = 4 * 1024 * 1024,
+ }, {
+- .name = "rootfs",
++ .name = "rootfs_onboard",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = MTDPART_SIZ_FULL,
+ }