aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-27 21:22:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-27 21:22:17 +0000
commit85708af23caad02fae17d94759612430a3469379 (patch)
treea09a9e09ad76eb875fbd3738caf2b395a3732905 /target/linux/rb532/image
parent3d33be9ac49b81616c8f05748c11a6a9b0c381dc (diff)
downloadmaster-187ad058-85708af23caad02fae17d94759612430a3469379.tar.gz
master-187ad058-85708af23caad02fae17d94759612430a3469379.tar.bz2
master-187ad058-85708af23caad02fae17d94759612430a3469379.zip
rb532: align partitions to 128KB
because block2mtd wants "erasesize must be a divisor of device size" since 3.15 Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45072 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/image')
-rw-r--r--target/linux/rb532/image/Makefile10
-rwxr-xr-xtarget/linux/rb532/image/gen_image.sh3
2 files changed, 11 insertions, 2 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index 706c768060..284b3d4510 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -63,10 +63,18 @@ define Image/cmdline/yaffs2
root=/dev/mtdblock1 rootfstype=yaffs2
endef
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
define Image/Build
+ $(call Image/Build/$(1),$(1))
$(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel
$(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
- ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).bin 4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
+ ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).bin \
+ 4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1) \
+ 128
endef
$(eval $(call BuildImage))
diff --git a/target/linux/rb532/image/gen_image.sh b/target/linux/rb532/image/gen_image.sh
index 8875834b9e..a2d6f4012a 100755
--- a/target/linux/rb532/image/gen_image.sh
+++ b/target/linux/rb532/image/gen_image.sh
@@ -4,11 +4,12 @@ KERNELSIZE="$2"
KERNELIMAGE="$3"
ROOTFSSIZE="$4"
ROOTFSIMAGE="$5"
+ALIGN="$6"
rm -f "$OUTPUT"
# create partition table
-set `ptgen -o "$OUTPUT" -h 16 -s 32 -t 0x27 -p ${KERNELSIZE}m -t 0x83 -p ${ROOTFSSIZE}m`
+set `ptgen -o "$OUTPUT" -h 16 -s 32 -l ${ALIGN} -t 0x27 -p ${KERNELSIZE}m -t 0x83 -p ${ROOTFSSIZE}m`
KERNELOFFSET="$(($1 / 512))"
ROOTFSOFFSET="$(($3 / 512))"