aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/image
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2011-05-04 08:47:00 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2011-05-04 08:47:00 +0000
commit65d3f379ba804b4fd52b453b9d84aacabe6f9a10 (patch)
tree6084b9e59251aee667c39ed882794c18f27c6057 /target/linux/rb532/image
parentd4178017142443f20b67094b366dbd9e138416a4 (diff)
downloadmaster-187ad058-65d3f379ba804b4fd52b453b9d84aacabe6f9a10.tar.gz
master-187ad058-65d3f379ba804b4fd52b453b9d84aacabe6f9a10.tar.bz2
master-187ad058-65d3f379ba804b4fd52b453b9d84aacabe6f9a10.zip
linux/rb532: use kernel and initramfs tags on image generation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26817 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/image')
-rw-r--r--target/linux/rb532/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index b7849cbda3..da4baaa48a 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -28,8 +28,13 @@ define Image/Prepare
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
+VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-kernel
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
+endif
+
define Image/BuildKernel
- $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+ $(CP) $(KDIR)/loader.elf $(VMLINUX)
endef
define Image/cmdline/jffs2-64k
@@ -64,9 +69,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
- define Image/BuildKernel
- $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
- endef
endif
$(eval $(call BuildImage))