aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-11 00:45:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-11 00:45:28 +0000
commit4f26f227eaeb277353b98142dc3ffff2b4afd52a (patch)
tree6d2828cfa21410aeb0eec28d0d656c4a047a1bcd /target/linux/rb532/image
parentd3ddbd6f0cb5716125ed1b6ab5184fca54763038 (diff)
downloadmaster-187ad058-4f26f227eaeb277353b98142dc3ffff2b4afd52a.tar.gz
master-187ad058-4f26f227eaeb277353b98142dc3ffff2b4afd52a.tar.bz2
master-187ad058-4f26f227eaeb277353b98142dc3ffff2b4afd52a.zip
rb532: preserve commandline-patched kernel images for faster kernel testing via netboot
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15766 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/image')
-rw-r--r--target/linux/rb532/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index a29ddf8280..9d0857dec8 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -54,8 +54,9 @@ root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
endef
define Image/Build
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
- ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
+ ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)