aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2016-06-24 13:05:13 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 13:05:13 +0200
commit7ec8f901a66150f3b5cdc5fc31d4bce86a84b773 (patch)
tree991cc8fb21a65d073d50eb071d476415ca8ae7c8 /target/linux/ramips
parent2f3df65a63078a2e48a731f8a4b0f139b6176304 (diff)
downloadmaster-187ad058-7ec8f901a66150f3b5cdc5fc31d4bce86a84b773.tar.gz
master-187ad058-7ec8f901a66150f3b5cdc5fc31d4bce86a84b773.tar.bz2
master-187ad058-7ec8f901a66150f3b5cdc5fc31d4bce86a84b773.zip
ramips: fix Netgear EX2700 images
Calling `cat foo bar | dd ... conv=sync` *may* add extraneous padding. Avoid this. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7620.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d6da803b52..935f755923 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -8,9 +8,9 @@ define Build/tplink-header
endef
define Build/pad-kernel-ex2700
- dd if=/dev/zero of=$@.pad bs=64 count=1 && cat $@ $@.pad \
- | dd of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
- && cat ex2700-fakeroot.uImage >> $@.new && rm $@.pad && mv $@.new $@
+ cp $@ $@.tmp && dd if=/dev/zero bs=64 count=1 >> $@.tmp \
+ && dd if=$@.tmp of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
+ && cat ex2700-fakeroot.uImage >> $@.new && rm $@.tmp && mv $@.new $@
endef
define Build/netgear-header