aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2016-06-24 13:09:21 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 13:09:21 +0200
commit6c67d1c0817485ad520d1c5c19e252f0b94ca041 (patch)
tree50fe20489e08d04a203c72d58ccd2ce3740558b2 /target/linux/ramips
parent850993467c17168c49723076f8caf8b29ba69d7f (diff)
downloadmaster-187ad058-6c67d1c0817485ad520d1c5c19e252f0b94ca041.tar.gz
master-187ad058-6c67d1c0817485ad520d1c5c19e252f0b94ca041.tar.bz2
master-187ad058-6c67d1c0817485ad520d1c5c19e252f0b94ca041.zip
ramips/image: Add Archer C50 to mt7620 Makefile
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 935f755923..33f94a48e9 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -50,6 +50,15 @@ define Device/ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
+define Device/ArcherC50
+ DTS := ArcherC50
+ KERNEL := $(KERNEL_DTB)
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j -r $(KDIR)/root.squashfs
+ DEVICE_TITLE := TP-Link ArcherC50
+endef
+TARGET_DEVICES += ArcherC50
+
ex2700_mtd_size=3866624
define Device/ex2700
DTS := EX2700