aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2016-06-24 13:02:47 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 13:02:47 +0200
commit3dd66d0eecbf859b5677f47a4a7f0e65527651ab (patch)
tree6a88462b10043100fd83cbffe2bf460e84739677 /target/linux/ramips
parenta7ccb5a1b33f422ef2116c4deeed7d793ffb913c (diff)
downloadmaster-187ad058-3dd66d0eecbf859b5677f47a4a7f0e65527651ab.tar.gz
master-187ad058-3dd66d0eecbf859b5677f47a4a7f0e65527651ab.tar.bz2
master-187ad058-3dd66d0eecbf859b5677f47a4a7f0e65527651ab.zip
ramips: fix Netgear EX2700 images
The previous image creation code would have failed if the unpadded kernel uImage size was less than 64 bytes from the next erase block boundary. Fix that. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7620.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d7acb1b8f9..d6da803b52 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -8,8 +8,9 @@ define Build/tplink-header
endef
define Build/pad-kernel-ex2700
- dd if=$@ of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
- && cat ex2700-fakeroot.uImage >> $@.new && mv $@.new $@
+ dd if=/dev/zero of=$@.pad bs=64 count=1 && cat $@ $@.pad \
+ | dd of=$@.new bs=64k conv=sync && truncate -s -64 $@.new \
+ && cat ex2700-fakeroot.uImage >> $@.new && rm $@.pad && mv $@.new $@
endef
define Build/netgear-header