aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt3883/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:42:52 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:42:52 +0000
commit67a8c469a91b9e165b3a54703fdf2057836c8a69 (patch)
treede87edd05a2033035740bba13ec6318b061ade72 /target/linux/ramips/rt3883/profiles
parent27f53b6560d97128bdc6c7d25c2a72d80565401b (diff)
downloadmaster-187ad058-67a8c469a91b9e165b3a54703fdf2057836c8a69.tar.gz
master-187ad058-67a8c469a91b9e165b3a54703fdf2057836c8a69.tar.bz2
master-187ad058-67a8c469a91b9e165b3a54703fdf2057836c8a69.zip
ralink: Add support for samsung cy-swr1100 wireless router
It is base on rt3662 soc with dual band 802.11n wireless router. Use rtl8367R switch chip. This patch adds a profile for this board. It use seama image header. so i also enable it on kernel config. Signed-off-by: michael lee <igvtee@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40908 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt3883/profiles')
-rw-r--r--target/linux/ramips/rt3883/profiles/samsung.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/rt3883/profiles/samsung.mk b/target/linux/ramips/rt3883/profiles/samsung.mk
new file mode 100644
index 0000000000..18f60d4a3c
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/samsung.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/CYSWR1100
+ NAME:=Samsung CY-SWR1100
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+
+define Profile/CYSWR1100/Description
+ Package set compatible with the Samsung CY-SWR1100 board.
+endef
+$(eval $(call Profile,CYSWR1100))