aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-04 08:33:12 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-04 08:33:12 +0000
commitf79a7116b0f912233e93031f110624f9345f34d4 (patch)
tree85b45a8571648fee0fb089cd77ebea7d6190ce45 /target/linux/ramips/rt305x
parent20b4e26c8a45acc69a564fd0e3e8191bec524091 (diff)
downloadmaster-187ad058-f79a7116b0f912233e93031f110624f9345f34d4.tar.gz
master-187ad058-f79a7116b0f912233e93031f110624f9345f34d4.tar.bz2
master-187ad058-f79a7116b0f912233e93031f110624f9345f34d4.zip
ramips: Add profiles for JCG routers
This patch adds profiles and support for building factory and sysupgrade images for JHR-N805R, JHR-N825R and JHR-N926R. Signed-off-by: Reinhard Max <reinhard@m4x.de> Reviewed-by: Torsten Duwe <duwe@lst.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48906 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/jcg.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/jcg.mk b/target/linux/ramips/rt305x/profiles/jcg.mk
new file mode 100644
index 0000000000..5029ca925f
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/jcg.mk
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/JCG
+ NAME=JCG Routers
+endef
+
+define Profile/JCG/Description
+ Builds images for JHR-N805R, JHR-N825R, and JHR-N926R.
+endef
+$(eval $(call Profile,JCG))
+
+define Profile/JHR-N805R
+ NAME:=JCG JHR-N805R
+endef
+
+define Profile/JHR-N805R/Description
+ Package set for JCG JHR-N805R
+endef
+$(eval $(call Profile,JHR-N805R))
+
+define Profile/JHR-N825R
+ NAME:=JCG JHR-N825R
+endef
+
+define Profile/JHR-N825R/Description
+ Package set for JCG JHR-N825R
+endef
+$(eval $(call Profile,JHR-N825R))
+
+define Profile/JHR-N926R
+ NAME:=JCG JHR-N926R
+endef
+
+define Profile/JHR-N926R/Description
+ Package set for JCG JHR-N926R
+endef
+$(eval $(call Profile,JHR-N926R))
+