aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-01 20:51:24 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-01 20:51:24 +0000
commita3ea08a8254c2d653bd9440441e59a9bfdc1394b (patch)
treebaaade8dd30a3574b4e0da69219f583c8b0e244d /target/linux/ramips/rt305x
parentc6ded2d17c8dee15a119191b3ca2e3efd924521f (diff)
downloadmaster-187ad058-a3ea08a8254c2d653bd9440441e59a9bfdc1394b.tar.gz
master-187ad058-a3ea08a8254c2d653bd9440441e59a9bfdc1394b.tar.bz2
master-187ad058-a3ea08a8254c2d653bd9440441e59a9bfdc1394b.zip
ramips: Add support for VoCore
This is based and tested on VoCore Alpha, but other stuff like status/eth LEDs are present on the final board revision + VoDock. All GPIOs are exported, except spi/i2c. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41939 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/vocore.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/vocore.mk b/target/linux/ramips/rt305x/profiles/vocore.mk
new file mode 100644
index 0000000000..11fb634beb
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/vocore.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/VOCORE
+ NAME:=VoCore
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-i2c-core kmod-i2c-ralink
+endef
+
+define Profile/VOCORE/Description
+ Package set for VoCore board
+endef
+
+$(eval $(call Profile,VOCORE))