aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-22 09:35:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-22 09:35:22 +0000
commit89329096dfb166cb55a7850997e21db0e377b103 (patch)
tree180cd16cb94b761be64ff8411dbca77454137ffd /target/linux/ramips/rt305x
parent35d648cb2e6290899e37b50302c88e676452f402 (diff)
downloadmaster-187ad058-89329096dfb166cb55a7850997e21db0e377b103.tar.gz
master-187ad058-89329096dfb166cb55a7850997e21db0e377b103.tar.bz2
master-187ad058-89329096dfb166cb55a7850997e21db0e377b103.zip
ramips: add support for Tenda 3G150B
Add suport for Tenda 3G150B: - cpu: Ralink RT5350F - flash: 4MB - ram: 32MB - 1x USB 2.0 - 1x RJ45 - one reset button - battery powered (BP-4L, 3.7V 1450mAh) Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44073 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/tenda.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/tenda.mk b/target/linux/ramips/rt305x/profiles/tenda.mk
index d9d94cfbb9..36ba822b44 100644
--- a/target/linux/ramips/rt305x/profiles/tenda.mk
+++ b/target/linux/ramips/rt305x/profiles/tenda.mk
@@ -5,6 +5,19 @@
# See /LICENSE for more information.
#
+define Profile/3G150B
+ NAME:=Tenda 3G150B
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/3G150B/Description
+ Package set for Tenda 3G150B board
+endef
+
+$(eval $(call Profile,3G150B))
+
define Profile/3G300M
NAME:=Tenda 3G300M
PACKAGES:=\