aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-06 04:52:07 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-06 04:52:07 +0000
commit5f9a01b40fb0006b63450e93945574f23440e5ac (patch)
treeb56ae92450971f27c937bb7b451a6c1a58c1a90c /target/linux/ramips/rt305x
parent9584e3b28b55637370ecacb06272872ffec140c9 (diff)
downloadmaster-187ad058-5f9a01b40fb0006b63450e93945574f23440e5ac.tar.gz
master-187ad058-5f9a01b40fb0006b63450e93945574f23440e5ac.tar.bz2
master-187ad058-5f9a01b40fb0006b63450e93945574f23440e5ac.zip
ramips: Support for RAMIPS based Tripmate HT-TM02 board
Provides support for the Tripmate HT-TM02 personal router including LEDs and reset button. “Mode” switch is not supported. New profile includes full set of packages required to enable LEDs, USB, and LUCI. Patches were applied against trunk snapshot r42649. Functionality has been tested in AP, basic wifi client, wifi router, and routed client modes - all good. Signed-off-by: Ron Curry <wingspinner@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42785 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/hootoo.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hootoo.mk b/target/linux/ramips/rt305x/profiles/hootoo.mk
new file mode 100644
index 0000000000..976226d5bd
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/hootoo.mk
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+
+define Profile/HT-TM02
+ NAME:=HOOTOO HT-TM02
+ PACKAGES:=\
+ wpad-mini \
+ kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio kmod-ledtrig-default-on \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-net usbutils \
+ kmod-scsi-core kmod-scsi-generic kmod-fs-ext4 \
+ kmod-usb-storage kmod-usb-storage-extras block-mount \
+ kmod-usb-serial kmod-usb-serial-ftdi kmod-gpio-button-hotplug \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 luci luci-mod-admin-full \
+ kmod-app-samba luci-theme-openwrt luci-proto-relay relayd nano \
+ fstools
+endef
+
+define Profile/HT-TM02/Description
+ Package set for HOOTOO HT-TM02 board
+endef
+
+$(eval $(call Profile,HT-TM02))
+