aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-12-10 14:13:01 +0000
committerJohn Crispin <blogic@openwrt.org>2012-12-10 14:13:01 +0000
commit24705010ad1a37ce7b5543c125abb7b4cbb4c102 (patch)
tree33876a93a69dbc7df386265a1bc6edf1aaa79daa /target/linux/ramips/rt305x
parentf7a9482416ccb4faf22ef1b1a584046d46788a27 (diff)
downloadmaster-187ad058-24705010ad1a37ce7b5543c125abb7b4cbb4c102.tar.gz
master-187ad058-24705010ad1a37ce7b5543c125abb7b4cbb4c102.tar.bz2
master-187ad058-24705010ad1a37ce7b5543c125abb7b4cbb4c102.zip
[ramips] add support for Hauppauge Broadway
This patch introduces OpenWRT support for the base Hauppauge/PCTV Broadway platform. It doesn't deal with the TV tuner or transcoder at this point, but the core functionality is working (Ethernet, wireless, USB, buttons, LEDs, etc). Signed-off-by: Devin Heitmueller <dheitmueller@kernellabs.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34595 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/config-3.31
-rw-r--r--target/linux/ramips/rt305x/config-3.62
-rw-r--r--target/linux/ramips/rt305x/profiles/broadway.mk19
3 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/config-3.3 b/target/linux/ramips/rt305x/config-3.3
index 7b6bafdf1b..8105b0fa6f 100644
--- a/target/linux/ramips/rt305x/config-3.3
+++ b/target/linux/ramips/rt305x/config-3.3
@@ -91,6 +91,7 @@ CONFIG_RT305X_MACH_ALL0256N=y
CONFIG_RT305X_MACH_ALL5002=y
CONFIG_RT305X_MACH_ARGUS_ATP52B=y
CONFIG_RT305X_MACH_BC2=y
+CONFIG_RT305X_MACH_BROADWAY=y
CONFIG_RT305X_MACH_CARAMBOLA=y
CONFIG_RT305X_MACH_DAP_1350=y
CONFIG_RT305X_MACH_DIR_300_REVB=y
diff --git a/target/linux/ramips/rt305x/config-3.6 b/target/linux/ramips/rt305x/config-3.6
index 86361af9e7..1971c2ac30 100644
--- a/target/linux/ramips/rt305x/config-3.6
+++ b/target/linux/ramips/rt305x/config-3.6
@@ -43,6 +43,7 @@ CONFIG_HAS_IOMEM=y
CONFIG_HAS_IOPORT=y
CONFIG_HAVE_ARCH_JUMP_LABEL=y
CONFIG_HAVE_ARCH_KGDB=y
+CONFIG_HAVE_CLK=y
CONFIG_HAVE_C_RECORDMCOUNT=y
CONFIG_HAVE_DMA_API_DEBUG=y
CONFIG_HAVE_DMA_ATTRS=y
@@ -96,6 +97,7 @@ CONFIG_RT305X_MACH_ALL0256N=y
CONFIG_RT305X_MACH_ALL5002=y
CONFIG_RT305X_MACH_ARGUS_ATP52B=y
CONFIG_RT305X_MACH_BC2=y
+CONFIG_RT305X_MACH_BROADWAY=y
CONFIG_RT305X_MACH_CARAMBOLA=y
CONFIG_RT305X_MACH_DAP_1350=y
CONFIG_RT305X_MACH_DIR_300_REVB=y
diff --git a/target/linux/ramips/rt305x/profiles/broadway.mk b/target/linux/ramips/rt305x/profiles/broadway.mk
new file mode 100644
index 0000000000..8e994bdb8c
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/broadway.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BROADWAY
+ NAME:=Hauppauge Broadway
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg \
+ kmod-ledtrig-usbdev restorefactory
+endef
+
+define Profile/BROADWAY/Description
+ Package set for Hauppauge Broadway
+endef
+
+$(eval $(call Profile,BROADWAY))