aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-10 08:24:56 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-10 08:24:56 +0000
commitecb32a2174fc391810491eccc0e3063e40c2ebb4 (patch)
tree1cdc9399acf9a0c3dbf805d13ee94e9c11f1ead8 /target/linux/ramips/rt305x/profiles
parenta4e76e8e46452f8d0cb0fb8ee09206ddad10f442 (diff)
downloadmaster-187ad058-ecb32a2174fc391810491eccc0e3063e40c2ebb4.tar.gz
master-187ad058-ecb32a2174fc391810491eccc0e3063e40c2ebb4.tar.bz2
master-187ad058-ecb32a2174fc391810491eccc0e3063e40c2ebb4.zip
ramips: add HAME MPR-A2 support
This patch adds support for HAME MPR-A2 router using a DTS file. The platform is Ralink RT5350. http://wiki.openwrt.org/toh/hame/mpr-a2 Signed-off-by: Dmitry Shmygov <shmygov@rambler.ru> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36898 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles')
-rw-r--r--target/linux/ramips/rt305x/profiles/hame.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hame.mk b/target/linux/ramips/rt305x/profiles/hame.mk
new file mode 100644
index 0000000000..1a85be7ba3
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/hame.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MPRA2
+ NAME:=HAME MPR-A2
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-netdev kmod-ledtrig-timer \
+ kmod-usb-acm kmod-usb-net kmod-usb-net-asix kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option \
+ usb-modeswitch usb-modeswitch-data comgt
+endef
+
+define Profile/MPRA2/Description
+ Package set for HAME MPR-A2 board
+endef
+
+$(eval $(call Profile,MPRA2))
+