aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 05:59:29 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 05:59:29 +0000
commit12880e48da1b9f092ea9b02477ace1bdcc9b6fe6 (patch)
treebf2ba461b75c327d549e636c98cb1476752fd626 /target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk
parente8ef99bc30247988949a4339d5683bbabbe2c5a2 (diff)
downloadmaster-187ad058-12880e48da1b9f092ea9b02477ace1bdcc9b6fe6.tar.gz
master-187ad058-12880e48da1b9f092ea9b02477ace1bdcc9b6fe6.tar.bz2
master-187ad058-12880e48da1b9f092ea9b02477ace1bdcc9b6fe6.zip
ramips: fix Olimex models, images and profiles names
Official names for RT5350F based OLinuXino products are "RT5350F-OLinuXino{,-EVB}" as on official manufacturer website. The following patch: * changes board names from "olinuxino-rt5350f{,-evb}" to "rt5350f-olinuxino{,-evb}" * changes filenames of dts and profile files * changes image filenames for Olimex RT5350F-OLinuXino{,-EVB} devices. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46623 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk b/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk
new file mode 100644
index 0000000000..3b201902b5
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT5350F-OLINUXINO
+ NAME:=RT5350F-OLinuXino
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-i2c-core kmod-i2c-ralink \
+ kmod-spi-dev
+endef
+
+define Profile/RT5350F-OLINUXINO/Description
+ Package set for RT5350F-OLinuXino board
+endef
+
+$(eval $(call Profile,RT5350F-OLINUXINO))