aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/huawei.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:01:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:01:38 +0000
commitc9c621207595e7ddcb07dd737aff732b94830b30 (patch)
treea5f73a97337f006b7047dca03e3fabe278e0488b /target/linux/ramips/rt305x/profiles/huawei.mk
parent84036d3104107843493b6849a512af1099647ef9 (diff)
downloadmaster-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.tar.gz
master-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.tar.bz2
master-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.zip
ramips: fix various mistakes in subtargets *.mk profiles
This patch: * fixes wrong indentation * fixes wrong names and descriptions (ex. Dlink -> D-Link) * changes filenames to manufacturer names * moves oem/unknown manufacturers boards to misc.mk profiles * combines profiles for boards from the same manufacturers in one file (ex. Olimex) * fix profile files structure (keep the same convention as in other targets, ex. ar71xx) in various .mk profiles, in ramips target. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46631 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/huawei.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/huawei.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/huawei.mk b/target/linux/ramips/rt305x/profiles/huawei.mk
new file mode 100644
index 0000000000..3223e76718
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/huawei.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HG255D
+ NAME:=Huawei HG255D
+ PACKAGES:=kmod-leds-gpio wpad-mini kmod-usb-dwc2
+endef
+
+define Profile/HG255D/Description
+ Package set for Huawei HG255D.
+endef
+$(eval $(call Profile,HG255D))