aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/dlink.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:01:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:01:38 +0000
commitc9c621207595e7ddcb07dd737aff732b94830b30 (patch)
treea5f73a97337f006b7047dca03e3fabe278e0488b /target/linux/ramips/rt305x/profiles/dlink.mk
parent84036d3104107843493b6849a512af1099647ef9 (diff)
downloadmaster-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.tar.gz
master-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.tar.bz2
master-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.zip
ramips: fix various mistakes in subtargets *.mk profiles
This patch: * fixes wrong indentation * fixes wrong names and descriptions (ex. Dlink -> D-Link) * changes filenames to manufacturer names * moves oem/unknown manufacturers boards to misc.mk profiles * combines profiles for boards from the same manufacturers in one file (ex. Olimex) * fix profile files structure (keep the same convention as in other targets, ex. ar71xx) in various .mk profiles, in ramips target. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46631 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/dlink.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/dlink.mk69
1 files changed, 0 insertions, 69 deletions
diff --git a/target/linux/ramips/rt305x/profiles/dlink.mk b/target/linux/ramips/rt305x/profiles/dlink.mk
deleted file mode 100644
index 5fc5709d73..0000000000
--- a/target/linux/ramips/rt305x/profiles/dlink.mk
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DIR615H1
- NAME:=Dlink DIR-615 H1
- PACKAGES:=\
- -kmod-usb-core -kmod-usb-dwc2 \
- -kmod-ledtrig-usbdev
-endef
-
-define Profile/DIR615H1/Description
- Package set for Dlink DIR-615 H1 board
-endef
-
-$(eval $(call Profile,DIR615H1))
-
-define Profile/DIR-615-D
- NAME:=Dlink DIR-615 D
- PACKAGES:=\
- -kmod-usb-core -kmod-usb-dwc2 \
- -kmod-ledtrig-usbdev
-endef
-
-define Profile/DIR-615-D/Description
- Package set for Dlink DIR-615 D board
-endef
-
-$(eval $(call Profile,DIR-615-D))
-
-define Profile/DCS930
- NAME:=Dlink DCS-930
- PACKAGES:=kmod-video-core kmod-video-uvc \
- kmod-sound-core kmod-usb-audio \
- kmod-usb-core kmod-usb-dwc2
-endef
-
-define Profile/DCS930/Description
- Package set for Dlink DCS-930 board
-endef
-
-$(eval $(call Profile,DCS930))
-
-define Profile/DCS930LB1
- NAME:=Dlink DCS-930L B1
- PACKAGES:=kmod-video-core kmod-video-uvc \
- kmod-sound-core kmod-usb-audio \
- kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/DCS930LB1/Description
- Package set for Dlink DCS-930L B1 board
-endef
-
-$(eval $(call Profile,DCS930LB1))
-
-define Profile/DIR610A1
- NAME:=Dlink DIR-610 A1
- PACKAGES:=kmod-ledtrig-netdev kmod-ledtrig-timer
-endef
-
-define Profile/DIR610A1/Description
- Package set for Dlink DIR610 A1 board
-endef
-
-$(eval $(call Profile,DIR610A1))