aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/asus.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-19 14:13:07 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-19 14:13:07 +0000
commite6af58406e7de2503b38d852162be0a3a0468943 (patch)
treee9c765bb4efbd11b92e637befa4b7efd2e52d93b /target/linux/ramips/rt305x/profiles/asus.mk
parentc4fae68f1381080622fb4d200f8e7a8d08bbe80a (diff)
downloadmaster-187ad058-e6af58406e7de2503b38d852162be0a3a0468943.tar.gz
master-187ad058-e6af58406e7de2503b38d852162be0a3a0468943.tar.bz2
master-187ad058-e6af58406e7de2503b38d852162be0a3a0468943.zip
ramips: cleanup some rt305x profiles
move both asus boards to asus.mk rename HW5503G profile to HW550-3G to match name in image/Makefile (fixes #16599) Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41271 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/asus.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/asus.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/asus.mk b/target/linux/ramips/rt305x/profiles/asus.mk
new file mode 100644
index 0000000000..fcf4aa4759
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/asus.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT-N10-PLUS
+ NAME:=Asus RT-N10+
+ PACKAGES:=kmod-leds-gpio wpa
+endef
+
+define Profile/RT-N10-PLUS/Description
+ Package set for Asus RT-N10+.
+endef
+
+define Profile/RT-N13U
+ NAME:=Asus RT-N13U
+ PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
+endef
+
+define Profile/RT-N13U/Description
+ Package set for Asus RT-N13U.
+endef
+
+$(eval $(call Profile,RT-N10-PLUS))
+$(eval $(call Profile,RT-N13U))