aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/allnet.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-04-25 19:03:01 +0000
committerJohn Crispin <blogic@openwrt.org>2013-04-25 19:03:01 +0000
commitecff443b65c881f93dee8ef643b70881535e88f2 (patch)
treee34d1665badfb0f41b2dfba58f7aecae60e0312c /target/linux/ramips/rt305x/profiles/allnet.mk
parente5adedfdd5b5381097ec8a22f14616749dfe8f70 (diff)
downloadmaster-187ad058-ecff443b65c881f93dee8ef643b70881535e88f2.tar.gz
master-187ad058-ecff443b65c881f93dee8ef643b70881535e88f2.tar.bz2
master-187ad058-ecff443b65c881f93dee8ef643b70881535e88f2.zip
ramips: introduce DTS for ALL5003
Prior to the switch to 3.8, ALL5002 and ALL5003 boards shared mach-all5002.c. With the change to DTS, this is no longer accurate, as ALL5002 is based on Rt3352 SoC while ALL5003 is based on Rt5350 SoC, therefore the corresponding rt5350.dtsi need to be included for ALL5003. Signed-off-by: Daniel Golle <dgolle@allnet.de> Patchwork: http://patchwork.openwrt.org/patch/3557/ Acked-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36435 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/allnet.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/allnet.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/allnet.mk b/target/linux/ramips/rt305x/profiles/allnet.mk
index 4ec2ffdd5c..858891f4d4 100644
--- a/target/linux/ramips/rt305x/profiles/allnet.mk
+++ b/target/linux/ramips/rt305x/profiles/allnet.mk
@@ -40,3 +40,15 @@ define Profile/ALL5002/Description
endef
$(eval $(call Profile,ALL5002))
+
+define Profile/ALL5003
+ NAME:=Allnet ALL5003
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-i2c-core kmod-i2c-gpio kmod-hwmon-lm92 kmod-gpio-pcf857x
+endef
+
+define Profile/ALL5003/Description
+ Package set for Allnet ALL5003
+endef
+
+$(eval $(call Profile,ALL5003))