aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/allnet.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-22 12:36:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-22 12:36:35 +0000
commit05e77cad671b9648c931219463e0c7df77fd7ca7 (patch)
tree036190c57b1e21640f43a81c0d96084aa5b85fbb /target/linux/ramips/rt305x/profiles/allnet.mk
parentb7fd6b817fc6fbf2178c3d1494e92e024f2238f5 (diff)
downloadmaster-187ad058-05e77cad671b9648c931219463e0c7df77fd7ca7.tar.gz
master-187ad058-05e77cad671b9648c931219463e0c7df77fd7ca7.tar.bz2
master-187ad058-05e77cad671b9648c931219463e0c7df77fd7ca7.zip
ramips: add profile for Allnet devices
Signed-off-by: Daniel Golle <dgolle@allnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33225 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/allnet.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/allnet.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/allnet.mk b/target/linux/ramips/rt305x/profiles/allnet.mk
new file mode 100644
index 0000000000..2aab5e2872
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/allnet.mk
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALL02393G
+ NAME:=Allnet ALL0239-3G
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/ALL02393G/Description
+ Package set for Allnet ALL0239-3G
+endef
+
+$(eval $(call Profile,ALL02393G))
+
+define Profile/ALL0256N
+ NAME:=Allnet ALL0256N
+ PACKAGES:=
+endef
+
+define Profile/ALL0256N/Description
+ Package set for Allnet ALL0256N
+endef
+
+$(eval $(call Profile,ALL0256N))
+
+define Profile/ALL5002
+ NAME:=Allnet ALL5002
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ALL5002/Description
+ Package set for Allnet ALL5002
+endef
+
+$(eval $(call Profile,ALL5002))