aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.6/103-ethernet.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-11-07 20:25:34 +0000
committerJohn Crispin <blogic@openwrt.org>2012-11-07 20:25:34 +0000
commit8b5e21cf9cd035cfc1659f017eef47543e829b99 (patch)
tree100695fb49c010bdb0ddef74b7b48a814480a222 /target/linux/ramips/patches-3.6/103-ethernet.patch
parent4ca51f2e6771c7e14e1e134619987b91a70328ea (diff)
downloadmaster-187ad058-8b5e21cf9cd035cfc1659f017eef47543e829b99.tar.gz
master-187ad058-8b5e21cf9cd035cfc1659f017eef47543e829b99.tar.bz2
master-187ad058-8b5e21cf9cd035cfc1659f017eef47543e829b99.zip
ramips: port patches to linux-3.6
Signed-off-by: Daniel Golle <dgolle@allnet.de> create mode 100644 target/linux/ramips/patches-3.6/001-mips-add-cp0-compare-irq-function.patch create mode 100644 target/linux/ramips/patches-3.6/010-mtd_fix_cfi_cmdset_0002_erase_status_check.patch create mode 100644 target/linux/ramips/patches-3.6/011-mtd-cfi_cmdset_0002-force-word-write.patch create mode 100644 target/linux/ramips/patches-3.6/100-mips-ralink-core.patch create mode 100644 target/linux/ramips/patches-3.6/101-rt288x_serial_driver_hack.patch create mode 100644 target/linux/ramips/patches-3.6/102-rt288x-pci-driver-hook.patch create mode 100644 target/linux/ramips/patches-3.6/103-ethernet.patch create mode 100644 target/linux/ramips/patches-3.6/104-ramips-watchdog-driver.patch create mode 100644 target/linux/ramips/patches-3.6/105-ramips-spi-driver.patch create mode 100644 target/linux/ramips/patches-3.6/105-usb_dwc_otg.patch create mode 100644 target/linux/ramips/patches-3.6/106-rt3883-pci-support.patch create mode 100644 target/linux/ramips/patches-3.6/200-rt3883-ehci-glue.patch create mode 100644 target/linux/ramips/patches-3.6/201-rt3883-ohci-glue.patch git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34108 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.6/103-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-3.6/103-ethernet.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.6/103-ethernet.patch b/target/linux/ramips/patches-3.6/103-ethernet.patch
new file mode 100644
index 0000000000..a3b402fb8e
--- /dev/null
+++ b/target/linux/ramips/patches-3.6/103-ethernet.patch
@@ -0,0 +1,20 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -145,6 +145,7 @@ source "drivers/net/ethernet/packetengin
+ source "drivers/net/ethernet/pasemi/Kconfig"
+ source "drivers/net/ethernet/qlogic/Kconfig"
+ source "drivers/net/ethernet/racal/Kconfig"
++source "drivers/net/ethernet/ramips/Kconfig"
+ source "drivers/net/ethernet/realtek/Kconfig"
+ source "drivers/net/ethernet/renesas/Kconfig"
+ source "drivers/net/ethernet/rdc/Kconfig"
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -55,6 +55,7 @@ obj-$(CONFIG_NET_PACKET_ENGINE) += packe
+ obj-$(CONFIG_NET_VENDOR_PASEMI) += pasemi/
+ obj-$(CONFIG_NET_VENDOR_QLOGIC) += qlogic/
+ obj-$(CONFIG_NET_VENDOR_RACAL) += racal/
++obj-$(CONFIG_NET_RAMIPS) += ramips/
+ obj-$(CONFIG_NET_VENDOR_REALTEK) += realtek/
+ obj-$(CONFIG_SH_ETH) += renesas/
+ obj-$(CONFIG_NET_VENDOR_RDC) += rdc/