aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.36/103-ethernet.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-05 20:14:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-05 20:14:38 +0000
commit2d6e16b89635e31cd22a694e934779cd6eced940 (patch)
tree92a150462751fbee787ce99a15c2d8ceddcefa86 /target/linux/ramips/patches-2.6.36/103-ethernet.patch
parenta0fc7e26a0e3572a8377549f44c504903235d7d5 (diff)
downloadmaster-187ad058-2d6e16b89635e31cd22a694e934779cd6eced940.tar.gz
master-187ad058-2d6e16b89635e31cd22a694e934779cd6eced940.tar.bz2
master-187ad058-2d6e16b89635e31cd22a694e934779cd6eced940.zip
ramips: add support for 2.6.36
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24270 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-2.6.36/103-ethernet.patch')
-rw-r--r--target/linux/ramips/patches-2.6.36/103-ethernet.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.36/103-ethernet.patch b/target/linux/ramips/patches-2.6.36/103-ethernet.patch
new file mode 100644
index 0000000000..404f885950
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.36/103-ethernet.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -614,6 +614,12 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config MIPS_RAMIPS_NET
++ tristate "Ethernet driver for rt288x/rt305x"
++ depends on MIPS_RALINK
++ help
++ This driver supports the etehrnet mac inside the ralink wisocs
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -222,6 +222,7 @@ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
++obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o
+ obj-$(CONFIG_ATARILANCE) += atarilance.o