aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.30
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2009-10-23 16:51:51 +0000
committerJohn Crispin <blogic@openwrt.org>2009-10-23 16:51:51 +0000
commitd363b3d5d7427a143d411936e0c00aebf1413050 (patch)
tree501c324505bf0e66efaa2ff177fd719e53be2540 /target/linux/ramips/patches-2.6.30
parent19fb687aad3af3666b9b1366902be60e12d1447a (diff)
downloadmaster-187ad058-d363b3d5d7427a143d411936e0c00aebf1413050.tar.gz
master-187ad058-d363b3d5d7427a143d411936e0c00aebf1413050.tar.bz2
master-187ad058-d363b3d5d7427a143d411936e0c00aebf1413050.zip
[ramips] adds ethernet driver, esw needs to be moved to swconfig, driver is missing rt288x support, not a platform device yet
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18128 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-2.6.30')
-rw-r--r--target/linux/ramips/patches-2.6.30/104-watchdog.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.30/104-watchdog.patch b/target/linux/ramips/patches-2.6.30/104-watchdog.patch
new file mode 100644
index 0000000000..793bea1c6c
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.30/104-watchdog.patch
@@ -0,0 +1,30 @@
+Index: linux-2.6.30.5/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-04 15:19:34.000000000 +0200
+@@ -764,6 +764,13 @@
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config RAMIPS_WDT
++ tristate "Ralink Watchdog Timer"
++ depends on MIPS_RALINK
++ help
++ Hardware driver for the built-in watchdog timer on Ralink MIPS SoCs.
++
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+Index: linux-2.6.30.5/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-04 15:19:34.000000000 +0200
+@@ -105,6 +105,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramipswdt.o
+
+ # PARISC Architecture
+