aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7688/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:07:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:07:38 +0000
commit8d5e529d09bc777828ee65eb3888dd4aea1dc471 (patch)
treef312e3032a825e8dc36535f280bb9f4f6453cd8d /target/linux/ramips/mt7688/profiles
parent765d67d621dabbe68dd939476e6777226f96cbd9 (diff)
downloadmaster-187ad058-8d5e529d09bc777828ee65eb3888dd4aea1dc471.tar.gz
master-187ad058-8d5e529d09bc777828ee65eb3888dd4aea1dc471.tar.bz2
master-187ad058-8d5e529d09bc777828ee65eb3888dd4aea1dc471.zip
ramips: add LinkIt Smart7688 support
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47203 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7688/profiles')
-rw-r--r--target/linux/ramips/mt7688/profiles/01-mediatek.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7688/profiles/01-mediatek.mk b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
index 02190dd3ab..0e24e0686c 100644
--- a/target/linux/ramips/mt7688/profiles/01-mediatek.mk
+++ b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
@@ -16,3 +16,15 @@ define Profile/mt7688/Description
Default package set compatible with most boards.
endef
$(eval $(call Profile,mt7688))
+
+define Profile/LinkIt7688
+ NAME:=LinkIt7688
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ uboot-envtools kmod-ledtrig-netdev
+endef
+
+define Profile/LinkIt7688/Description
+ Default package set compatible with LinkIt Smart7688 dev board.
+endef
+$(eval $(call Profile,LinkIt7688))