aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-12 07:38:06 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-12 07:38:06 +0000
commit3493985b2b277ebdb762fc8a5bfb1b94c1994e73 (patch)
tree00b6f08cab505f825a8b7c4f52872ae14eb6d2a5 /target/linux/ramips/mt7621
parentc4c9a719f166242e9e2bc7c20655f68051258c0f (diff)
downloadmaster-187ad058-3493985b2b277ebdb762fc8a5bfb1b94c1994e73.tar.gz
master-187ad058-3493985b2b277ebdb762fc8a5bfb1b94c1994e73.tar.bz2
master-187ad058-3493985b2b277ebdb762fc8a5bfb1b94c1994e73.zip
ramips: add support for Ubiquiti EdgeRouter X (UBNT-ERX)
This router is based on MT7621 SoC, no wifi, no usb, nand. Works: * Boots. * Ethernet. * Switch. * Button (reset). * Flashing OpenWrt from stock firmware. * Upgrading OpenWrt. Doesn't work: * No GPIO leds. All leds are controlled by switch, but stock firmware was able to control them. * SoC has crypto engine but no open driver. * SoC has nat acceleration, but no open driver. * This router has 2MB spi flash soldered in but MT nand/spi drivers do not support pin sharing, so it is not accessable and disabled. Stock firmware could read it and it was empty. * PoE out. Router has serial pins populated. If looking at the top of the router, then counting from Eth sockets pins go as: 'GND, RX, TX, GND'. 3.3v, 57600. U-boot bootloader supports tftpboot, controlled from serial. This router has two kernel partitions: 'live' and 'backup'. They are swapped during flashing (on both stock and OpenWrt). Active partition is controlled by a flag in a factory partition. U-boot has custom command to switch active kernel partition. Kernel partitions are 'bare flash' 3MB. Stock bootloader has no UBI support. Stock rootfs is UBIFS. Flashing procedure. Stock firmware uses custom kernel patch to mount squashfs from a file that is located on UBIFS volume. This makes wiping out this volume from within stock firmware difficult. Instead this patch builds image that is flashable by stock firmware and contains initrams image (with minimal set of packages to fit into kernel partition). Once this is flashed one can reboot into initramfs OpenWrt and use sysupgrade to flash OpenWrt including rootfs into nand. Note: factory image is only built if initramfs image is enabled. Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47881 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621')
-rw-r--r--target/linux/ramips/mt7621/profiles/ubnt.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/ubnt.mk b/target/linux/ramips/mt7621/profiles/ubnt.mk
new file mode 100644
index 0000000000..b66b206694
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/ubnt.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBNT-ERX
+ NAME:=Ubiquiti EdgeRouter X
+ FEATURES+=nand -usb
+ PACKAGES:=-kmod-mt76 -wpad-mini -kmod-cfg80211
+endef
+
+define Profile/UBNT-ERX/Description
+ Package set compatible with the Ubiquiti EdgeRouter X
+endef
+$(eval $(call Profile,UBNT-ERX))