aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:01:38 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:01:38 +0000
commitc9c621207595e7ddcb07dd737aff732b94830b30 (patch)
treea5f73a97337f006b7047dca03e3fabe278e0488b /target/linux/ramips/mt7621/profiles
parent84036d3104107843493b6849a512af1099647ef9 (diff)
downloadmaster-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.tar.gz
master-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.tar.bz2
master-187ad058-c9c621207595e7ddcb07dd737aff732b94830b30.zip
ramips: fix various mistakes in subtargets *.mk profiles
This patch: * fixes wrong indentation * fixes wrong names and descriptions (ex. Dlink -> D-Link) * changes filenames to manufacturer names * moves oem/unknown manufacturers boards to misc.mk profiles * combines profiles for boards from the same manufacturers in one file (ex. Olimex) * fix profile files structure (keep the same convention as in other targets, ex. ar71xx) in various .mk profiles, in ramips target. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46631 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/firefly.mk12
-rw-r--r--target/linux/ramips/mt7621/profiles/misc.mk (renamed from target/linux/ramips/mt7621/profiles/pbr-m1.mk)6
-rw-r--r--target/linux/ramips/mt7621/profiles/storylink.mk (renamed from target/linux/ramips/mt7621/profiles/sap-g3200u3.mk)0
3 files changed, 8 insertions, 10 deletions
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
index 501a32b557..bc50ab4ed7 100644
--- a/target/linux/ramips/mt7621/profiles/firefly.mk
+++ b/target/linux/ramips/mt7621/profiles/firefly.mk
@@ -1,18 +1,18 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-define Profile/Firefly
- NAME:=Firefly Device
+define Profile/FIREWRT
+ NAME:=Firefly FireWRT
PACKAGES:=\
kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
kmod-ledtrig-usbdev
endef
-define Profile/Firefly/Description
- Default package set compatible with most boards.
+define Profile/FIREWRT/Description
+ Package set compatible with the Firefly FireWRT board.
endef
-$(eval $(call Profile,Firefly))
+$(eval $(call Profile,FIREWRT))
diff --git a/target/linux/ramips/mt7621/profiles/pbr-m1.mk b/target/linux/ramips/mt7621/profiles/misc.mk
index 9773b3174b..9db0cd561f 100644
--- a/target/linux/ramips/mt7621/profiles/pbr-m1.mk
+++ b/target/linux/ramips/mt7621/profiles/misc.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,15 +7,13 @@
define Profile/PBR-M1
NAME:=PBR-M1 Device
+ FEATURES+=rtc
PACKAGES:=\
kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
kmod-usb3-mt7621 kmod-rtc-pcf8563
endef
-
-FEATURES+=rtc
-
define Profile/PBR-M1/Description
Default package set compatible with most boards.
endef
diff --git a/target/linux/ramips/mt7621/profiles/sap-g3200u3.mk b/target/linux/ramips/mt7621/profiles/storylink.mk
index 9ca4a2f743..9ca4a2f743 100644
--- a/target/linux/ramips/mt7621/profiles/sap-g3200u3.mk
+++ b/target/linux/ramips/mt7621/profiles/storylink.mk