aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-20 06:34:28 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-20 06:34:28 +0000
commit9286ab00d3e9b5d11d489a557871a2879ef93a02 (patch)
tree24d0a4692e6e30aad7b49344286b30d40224ba40 /target/linux/ramips/mt7621/profiles
parent410d22ac0358660dc54ffc100b023e29bc90133f (diff)
downloadmaster-187ad058-9286ab00d3e9b5d11d489a557871a2879ef93a02.tar.gz
master-187ad058-9286ab00d3e9b5d11d489a557871a2879ef93a02.tar.bz2
master-187ad058-9286ab00d3e9b5d11d489a557871a2879ef93a02.zip
ralink: add support for firewrt
this is a mt7621 based board Signed-off-by: wengbj <linux.c@foxmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44055 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/firefly.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
new file mode 100644
index 0000000000..c8292b0d00
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/firefly.mk
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Firefly
+ NAME:=Firefly Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-usb-storage mount-utils usbutils \
+ kmod-sdhci-mt7620 \
+ kmod-fs-ext3 kmod-fs-vfat kmod-fs-ntfs \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 \
+ kmod-ledtrig-usbdev \
+ kmod-ata-core \
+ luci \
+ kmod-mt76
+endef
+
+define Profile/Firefly/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Firefly))