aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:13 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:13 +0000
commit530b8f83d77b21855520fc08266ed29b74efc893 (patch)
tree2e2594371a080d9b2a3c35926bfc4141bfa4a8a2 /target/linux/ramips/mt7621/profiles
parent0065f15e56d28a20eb9d1de1ccb446fe3093b822 (diff)
downloadmaster-187ad058-530b8f83d77b21855520fc08266ed29b74efc893.tar.gz
master-187ad058-530b8f83d77b21855520fc08266ed29b74efc893.tar.bz2
master-187ad058-530b8f83d77b21855520fc08266ed29b74efc893.zip
ramips: add additional support for MQmaker WiTi board
The board is based on mt7621AT cpu, and has 16mb nor flash, 256mb of ram, 2 sata ports, microsd card slot, 1 USB 3.0 port and at least one 2.4 and one 5 ghz antenna. This is the 6th submission that adds support for XHCI in the device tree file, along with switching the location of the 2 radio's and addition of the kmod-i2c-mt7621 in the default packages of the profile. Signed-off-by: Sebastian Careba <nitroshift@yahoo.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47845 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/mqmaker.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/mqmaker.mk b/target/linux/ramips/mt7621/profiles/mqmaker.mk
new file mode 100644
index 0000000000..ae35e7dc66
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/mqmaker.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/witi
+ NAME:=MQmaker WiTi
+ FEATURES+=rtc
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-rtc-pcf8563 kmod-i2c-mt7621
+endef
+
+define Profile/witi/Description
+ Package set compatible with MQmaker WiTi board.
+endef
+$(eval $(call Profile,witi))