aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-15 18:45:22 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-15 18:45:22 +0000
commitffaee94bac564f21df4e6759c09894ba4c63a825 (patch)
treefb88ed88ac3bf4dca493f916a5e951bb5c5719c3 /target/linux/ramips/mt7620
parent6ed31331080728a23d8ba71d7959ff447240a41f (diff)
downloadmaster-187ad058-ffaee94bac564f21df4e6759c09894ba4c63a825.tar.gz
master-187ad058-ffaee94bac564f21df4e6759c09894ba4c63a825.tar.bz2
master-187ad058-ffaee94bac564f21df4e6759c09894ba4c63a825.zip
ramips: Add support for Phicomm PSG1208
This patch adds support for Phicomm PSG1208.This is a router with MT7620A SoC with 8M flash and 64M ram. The WPS led is uesd as status_led because the power light can't be controlled with GPIO. It seems that the 5g wifi led is connected to MT7612E and it can't be controlled with GPIO too. Signed-off-by: Chuanhong Guo <gch981213@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48721 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/phicomm.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/phicomm.mk b/target/linux/ramips/mt7620/profiles/phicomm.mk
new file mode 100644
index 0000000000..e083a4c975
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/phicomm.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PSG1208
+ NAME:=Phicomm PSG1208
+ PACKAGES:=kmod-mt76
+endef
+
+define Profile/PSG1208/Description
+ Default package set for Phicomm PSG1208.
+endef
+$(eval $(call Profile,PSG1208))