aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620/profiles/elecom.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-21 19:46:59 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-21 19:46:59 +0000
commit3462032337eb98e8bd6d84bacd85a90669255d9e (patch)
tree2ff008f54ff1dd8e0e601965ac048a3b23eec6d2 /target/linux/ramips/mt7620/profiles/elecom.mk
parent92b2622ff8773a6953955fed220652d95c350d26 (diff)
downloadmaster-187ad058-3462032337eb98e8bd6d84bacd85a90669255d9e.tar.gz
master-187ad058-3462032337eb98e8bd6d84bacd85a90669255d9e.tar.bz2
master-187ad058-3462032337eb98e8bd6d84bacd85a90669255d9e.zip
ramips: add support for ELECOM WRH-300CR
ELECOM WRH-300CR is MT7620N based very small Wi-Fi router with 64MiB DDR2 SDRAM, 16MiB SPI Flash, one fast ethernet port, and (internal but easy-to-access) UART. it also has internal USB hub and USB card reader which provide one USB port, one SD card slot, and one microSD card slot. Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com> Signed-off-by: FUKAUMI Naoki <naobsd@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49211 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620/profiles/elecom.mk')
-rw-r--r--target/linux/ramips/mt7620/profiles/elecom.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/elecom.mk b/target/linux/ramips/mt7620/profiles/elecom.mk
new file mode 100644
index 0000000000..5c84c92715
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/elecom.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRH-300CR
+ NAME:=ELECOM WRH-300CR
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-usb-storage \
+ kmod-scsi-core kmod-fs-ext4 block-mount
+endef
+
+define Profile/WRH-300CR/Description
+ Package set optimized for the ELECOM WRH-300CR.
+endef
+$(eval $(call Profile,WRH-300CR))