aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:07:54 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:07:54 +0000
commit30e58b383eef889b9573867ba9f3f73dc01a5a87 (patch)
treed91297a781420d3edbb2f60c9e10da548d8fd348 /target/linux/ramips/modules.mk
parent43f0639aae90e44f73ff61eba2a442ff151af313 (diff)
downloadmaster-187ad058-30e58b383eef889b9573867ba9f3f73dc01a5a87.tar.gz
master-187ad058-30e58b383eef889b9573867ba9f3f73dc01a5a87.tar.bz2
master-187ad058-30e58b383eef889b9573867ba9f3f73dc01a5a87.zip
ramips: add alsa support
add the SDK alsa driver. this has only been tested on mt7628/88 and wm8960. mt7620 is only compile tested. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk29
1 files changed, 28 insertions, 1 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 503a1e55a1..bfb9bcd826 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -56,7 +56,7 @@ $(eval $(call KernelPackage,i2c-mt7621))
define KernelPackage/sound-mt7620
TITLE:=MT7620 PCM/I2S Alsa Driver
- DEPENDS:=@TARGET_ramips_mt7620 +kmod-sound-soc-core +kmod-regmap
+ DEPENDS:=@TARGET_ramips_mt7620 +kmod-sound-soc-core +kmod-regmap @BROKEN
KCONFIG:= \
CONFIG_SND_MT7620_SOC_I2S \
CONFIG_SND_MT7620_SOC_WM8960
@@ -73,3 +73,30 @@ define KernelPackage/sound-mt7620/description
endef
$(eval $(call KernelPackage,sound-mt7620))
+
+
+define KernelPackage/sound-mtk
+ TITLE:=Mediatek I2S Alsa Driver
+ DEPENDS:= +kmod-sound-soc-core +kmod-regmap +kmod-i2c-ralink @(TARGET_ramips_mt7628||TARGET_ramips_mt7688||TARGET_ramips_mt7620)
+ KCONFIG:= \
+ CONFIG_SND_MT76XX_SOC \
+ CONFIG_SND_MT76XX_I2S \
+ CONFIG_SND_MT76XX_PCM \
+ CONFIG_SND_SOC_WM8960
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/mtk/ralink_gdma.ko \
+ $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-i2s-ctl.ko \
+ $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-i2s.ko \
+ $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-pcm.ko \
+ $(LINUX_DIR)/sound/soc/mtk/snd-soc-mt76xx-machine.ko \
+ $(LINUX_DIR)/sound/soc/mtk/i2c_wm8960.ko \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
+ AUTOLOAD:=$(call AutoLoad,90,ralink_gdma snd-soc-wm8960 i2c_wm8960 snd-soc-mt76xx-i2s-ctl snd-soc-mt76xx-i2s snd-soc-mt76xx-pcm snd-soc-mt76xx-machine)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-mtk/description
+ Alsa modules for ralink i2s controller.
+endef
+
+$(eval $(call KernelPackage,sound-mtk))