aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-24 09:09:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-24 09:09:22 +0000
commitf321f09da7adfa5aa8dd0c3dcee8dfc5628811d4 (patch)
tree703c4e0edad3d05c5f7855eb90e288aacba3a1db /target/linux/ramips/image
parenta45e4b063444ee8ab4b862b7f9e1b24a4737abaa (diff)
downloadmaster-187ad058-f321f09da7adfa5aa8dd0c3dcee8dfc5628811d4.tar.gz
master-187ad058-f321f09da7adfa5aa8dd0c3dcee8dfc5628811d4.tar.bz2
master-187ad058-f321f09da7adfa5aa8dd0c3dcee8dfc5628811d4.zip
ramips: add support for STORYLiNK SAP-G3200U3
STORYLiNK SAP-G3200U3 is an AC1200 router based on MT7621AT+MT7602EN+MT7612EN. It has 128MB DDR3, 8MB NOR FLASH, 5-port Gbps switch and 1x USB 3.0. The following patch adds support for this device. Tested and working: * ethernet * both WiFi radios * USB 3.0 * buttons * ethernet switch and USB diag LEDs * UART * GPIOs Tested and not working: * LEDs for WiFi radios (connected with WiFi chips, not supported in mt76?) * failsafe mode (known problem, needs workaround like other MTK based devices) More information in Wiki: http://wiki.openwrt.org/toh/storylink/sap-g3200u3 Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46454 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index b71d935a93..46307ecd2c 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -926,7 +926,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3
endif
define Device/mt7621
@@ -972,6 +972,10 @@ define Device/pbr-m1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+define Device/sap-g3200u3
+ DTS := SAP-G3200U3
+endef
+
#
# MT7628 Profiles
#