aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-04 08:33:17 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-04 08:33:17 +0000
commitd192740e04044530fa0d3f495e084b86b9139a89 (patch)
tree2cea8eb62658e4e3360c45c4d29f21959d845481 /target/linux/ramips/image
parent68149a719d8c6064fbc67bda731639136f2dcea0 (diff)
downloadmaster-187ad058-d192740e04044530fa0d3f495e084b86b9139a89.tar.gz
master-187ad058-d192740e04044530fa0d3f495e084b86b9139a89.tar.bz2
master-187ad058-d192740e04044530fa0d3f495e084b86b9139a89.zip
ramips: mt7621: fix WF-2881 for ubi split
This patch fix firmware split for WF-2881 which was previously manually partitioned. Signed-off-by: YounJae Rho <luxflow@live.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48908 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index eb50cddeaf..f5e8e58ef9 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1115,9 +1115,10 @@ define Device/wf-2881
DTS := WF-2881
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- KERNEL_SIZE := 2097152
FILESYSTEMS := squashfs
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+ IMAGE_SIZE := 132382720
+ KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+ IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-erx