aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-09 10:32:37 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-09 10:32:37 +0000
commitbd60aa0e69df782a291d6ea7a55495898ee78c4d (patch)
tree0043197b0b6542e1c755035574af0c0772630944 /target/linux/ramips/image
parente9d844e3e8cfeb864ce87d85466bf57eadb4bf96 (diff)
downloadmaster-187ad058-bd60aa0e69df782a291d6ea7a55495898ee78c4d.tar.gz
master-187ad058-bd60aa0e69df782a291d6ea7a55495898ee78c4d.tar.bz2
master-187ad058-bd60aa0e69df782a291d6ea7a55495898ee78c4d.zip
ramips: Add support for Microduino MicroWRT
MicroWRT is an wireless router with 2 USB,1 ethernet port. It has a 16M flash and 64M DDR2 RAM. You can use most interface, such as i2c, SPI, i2s and PCIe. Besides that there are three expansion borad to combine with the core board. The detailed information, please refer to https://www.microduino.cc/wiki/index.php?title=Main_Page This patch adds support for it. Because there is only one port,so disabled VLAN and use eth0 as lan port. and only a power LED control by power pin. Signed-off-by: 盛凯 <shengkai81@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45331 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 743f7b4cf6..e6b5112d3e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -865,6 +865,8 @@ Image/Build/Profile/XIAOMI-MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1)
Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
Image/Build/Profile/ArcherC20i=$(call BuildFirmware/Tplink/$(1),$(1),ArcherC20i,ArcherC20i)
+microwrt_mtd_size=16515072
+Image/Build/Profile/MicroWRT=$(call BuildFirmware/CustomFlash/$(1),$(1),microwrt,MicroWRT,$(microwrt_mtd_size))
ifeq ($(SUBTARGET),mt7620)
@@ -895,6 +897,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/ZTE-Q7,$(1))
$(call Image/Build/Profile/ZBT-WA05,$(1))
$(call Image/Build/Profile/ArcherC20i,$(1))
+ $(call Image/Build/Profile/MicroWRT,$(1))
endef
endif