aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-01 08:31:46 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-01 08:31:46 +0000
commit9f366431fcd421e91094d286b36a18707769e714 (patch)
tree07fc3c0c7e0896d8fd5c57c2940fcf4eba84ab3f /target/linux/ramips/image
parent12102917e04b400040589c819b2cfeee7eb4e454 (diff)
downloadmaster-187ad058-9f366431fcd421e91094d286b36a18707769e714.tar.gz
master-187ad058-9f366431fcd421e91094d286b36a18707769e714.tar.bz2
master-187ad058-9f366431fcd421e91094d286b36a18707769e714.zip
ramips: Add support for ZTE Q7
ZTE Q7 is a wireless router with SD Card,USB,1 ethernet port and a battery.It used MT7620a SoC. I can,t find any information about this router on ZTE's website. But I found this : http://en.cctairmobi.com/plus/list.php?tid=40 This router is the same as ZTE Q7 and later I found that both routers are made by the same company:-D This patch adds support for it. Because there is only one port,I disabled VLAN and use eth0 as lan port. I could only create a sysupgrade firmware because I don't know how the orignal webpage check the uploaded image:-( Signed-off-by: 郭传鈜 <gch981213@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45208 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 14f6f1ef7e..743f7b4cf6 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -862,6 +862,7 @@ Image/Build/Profile/WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),wr8305rt,W
Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
Image/Build/Profile/WT3020=$(call BuildFirmware/PorayDualSize/$(1),$(1),wt3020,WT3020)
Image/Build/Profile/XIAOMI-MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1),xiaomi-miwifi-mini,XIAOMI-MIWIFI-MINI)
+Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
Image/Build/Profile/ArcherC20i=$(call BuildFirmware/Tplink/$(1),$(1),ArcherC20i,ArcherC20i)
@@ -891,6 +892,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WRTNODE,$(1))
$(call Image/Build/Profile/WT3020,$(1))
$(call Image/Build/Profile/XIAOMI-MIWIFI-MINI,$(1))
+ $(call Image/Build/Profile/ZTE-Q7,$(1))
$(call Image/Build/Profile/ZBT-WA05,$(1))
$(call Image/Build/Profile/ArcherC20i,$(1))
endef