aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-24 09:11:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-24 09:11:56 +0000
commit7b4ff671b7c416297d8be63b5eba44800f45f1bd (patch)
tree653516268531642298a3b930a8881b35d869ea64 /target/linux/ramips/image
parentb4e8cb9bc50f7e474c73542083a2d62be2c83547 (diff)
downloadmaster-187ad058-7b4ff671b7c416297d8be63b5eba44800f45f1bd.tar.gz
master-187ad058-7b4ff671b7c416297d8be63b5eba44800f45f1bd.tar.bz2
master-187ad058-7b4ff671b7c416297d8be63b5eba44800f45f1bd.zip
ramips: add subtarget for mt7688
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46473 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 46307ecd2c..409ff26575 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -988,6 +988,20 @@ define Image/Build/Profile/Default
endef
endif
+
+#
+# MT7688 Profiles
+#
+
+Image/Build/Profile/mt7688=$(call BuildFirmware/Default16M/$(1),$(1),mt7688,MT7688)
+
+ifeq ($(SUBTARGET),mt7688)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/mt7688,$(1))
+endef
+endif
+
+
ifndef TARGET_DEVICES
#
# Generic Targets - only needed for legacy image building code