aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-17 14:06:13 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-17 14:06:13 +0000
commit75b65571c9d1442c9ca80a82c1d848c0e9886e16 (patch)
treedb0f8a7d3cde78b8c35dbb8d3f22400a0e7d111a /target/linux/ramips/image
parent1f0e7b120580e15d348975c0359480306675c2fe (diff)
downloadmaster-187ad058-75b65571c9d1442c9ca80a82c1d848c0e9886e16.tar.gz
master-187ad058-75b65571c9d1442c9ca80a82c1d848c0e9886e16.tar.bz2
master-187ad058-75b65571c9d1442c9ca80a82c1d848c0e9886e16.zip
ramips: add support for Intenso Memory 2 Move USB 3.0
This adds support for a rt5350-based "portable nas" solution from Intenso. The board comes with 32M RAM and 8M Flash, the built-in HDD is connected/accessible via a usb3.0<->sata bridge VLI VL701. The device has 1 Ethernet port (100M/10M), 1 micro b usb 3.0 socket (for charging the battery, or accessing the hdd directly). Wireless connectivity is provided by the rt5350 SoC [i.e.: 802.11n 1x1 2.4 GHz with a pcb antenna.] Serial, leds, wifi, ethernet and usb are tested and as far as I can tell: they are working fine (tm). Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44001 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 21c8a8ddc9..5e4cea35ac 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -546,6 +546,8 @@ Image/Build/Profile/NCS601W=$(call BuildFirmware/Default8M/$(1),$(1),ncs601W,NCS
nw718_mtd_size=3801088
Image/Build/Profile/NW718=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),nw718m,NW718,$(nw718_mtd_size),ARA1B4NCRNW718;1,factory)
+Image/Build/Profile/M2M=$(call BuildFirmware/Default8M/$(1),$(1),m2m,M2M,Linux Kernel Image)
+
Image/Build/Profile/OMNI-EMB=$(call BuildFirmware/Default8M/$(1),$(1),omni-emb,OMNI-EMB)
Image/Build/Profile/OMNI-PLUG=$(call BuildFirmware/Default8M/$(1),$(1),omni-plug,OMNI-PLUG)
@@ -694,6 +696,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/HT-TM02,$(1))
$(call Image/Build/Profile/HW550-3G,$(1))
$(call Image/Build/Profile/IP2202,$(1))
+ $(call Image/Build/Profile/M2M,$(1))
$(call Image/Build/Profile/M3,$(1))
$(call Image/Build/Profile/M4,$(1))
$(call Image/Build/Profile/MOFI3500-3GN,$(1))