aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-28 10:56:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-28 10:56:24 +0000
commit5ce157d053852705977d08e8983717e954ec74ee (patch)
tree491f55d1fd5dcf804b61dddd843ebf4afeec021d /target/linux/ramips/image
parentbbbe814948834240891701a86d1cdc9dc7ea9d4e (diff)
downloadmaster-187ad058-5ce157d053852705977d08e8983717e954ec74ee.tar.gz
master-187ad058-5ce157d053852705977d08e8983717e954ec74ee.tar.bz2
master-187ad058-5ce157d053852705977d08e8983717e954ec74ee.zip
ramips: rt305x: add support for the DIR-600 B1,B2 boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27808 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index e84d468609..dde5ca89ad 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -104,13 +104,15 @@ mtd_dir300b1_kernel_part_size=851968
mtd_dir300b1_rootfs_part_size=3014656
define Image/Build/Template/DIR300B1
$(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_dir300b1,$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
- mkwrgimg -s wrgn23_dlwbr_dir300b -d /dev/mtdblock/2 \
+ mkwrgimg -s $(4) -d /dev/mtdblock/2 \
-i $(call imgname,$(1),$(2))-sysupgrade.bin \
-o $(call imgname,$(1),$(2))-factory.bin
endef
define Image/Build/Profile/DIR300B1
- $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1)
+ $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
+ $(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
+ $(call Image/Build/Template/DIR300B1,$(1),dir-600-b2,DIR-600-B2,wrgn23_dlwbr_dir600b)
endef
define Image/Build/Profile/FONERA20N