aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-12-13 10:53:34 +0000
committerJohn Crispin <blogic@openwrt.org>2013-12-13 10:53:34 +0000
commit490134a16728228ee67880f01402d0f92a823872 (patch)
tree39b2da9ffed609ea19d00804cab95a4cbbf80080 /target/linux/ramips/image
parentd6864eb56d397a59b4172e2f78cae2a243ece1c0 (diff)
downloadmaster-187ad058-490134a16728228ee67880f01402d0f92a823872.tar.gz
master-187ad058-490134a16728228ee67880f01402d0f92a823872.tar.bz2
master-187ad058-490134a16728228ee67880f01402d0f92a823872.zip
ralink: add mt7621 support
there are still various missing pieces for full support. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39040 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 32047ccfed..82addb27f8 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -29,10 +29,16 @@ define kernel_entry
-a 0x88000000 -e 0x88000000
endef
else
+ifeq ($(CONFIG_SOC_MT7621),y)
+define kernel_entry
+-a 0x80001000 -e 0x80001000
+endef
+else
define kernel_entry
-a 0x80000000 -e 0x80000000
endef
endif
+endif
define MkCombineduImage
$(call PatchKernelLzma,$(2),$(3))
@@ -649,6 +655,19 @@ endif
#
+# MT7621 Profiles
+#
+
+Image/Build/Profile/MT7621=$(call BuildFirmware/Default4M/$(1),$(1),mt7621,MT7621)
+
+ifeq ($(SUBTARGET),mt7621)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/MT7621,$(1))
+endef
+endif
+
+
+#
# Generic Targets
#
define Image/BuildKernel