aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 18:20:40 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 18:20:40 +0000
commit3b140c6fe45781d79cebe3c2ef6208f5d556b6bb (patch)
tree36d8e78be2d8938670758b285e9d644e92b9eac2 /target/linux/ramips/image
parent0dc621e3d97f9e9ca5ed68c2c08f695f6ae408a7 (diff)
downloadmaster-187ad058-3b140c6fe45781d79cebe3c2ef6208f5d556b6bb.tar.gz
master-187ad058-3b140c6fe45781d79cebe3c2ef6208f5d556b6bb.tar.bz2
master-187ad058-3b140c6fe45781d79cebe3c2ef6208f5d556b6bb.zip
ramips: add support for PandoraBox PBR-M1
This patch is for PandoraBox PBR-M1 which is based on mt7621, all the features work fine, including rtc, leds, button, usb3.0, etc. Signed-off-by: tymon <banglang.huang@foxmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46041 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 106cb2db3d..afbe56770f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -919,7 +919,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1
endif
define Device/mt7621
@@ -956,6 +956,11 @@ define Device/firewrt
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+define Device/pbr-m1
+ DTS := PBR-M1
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
#
# MT7628 Profiles
#