aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-24 18:29:26 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-24 18:29:26 +0000
commit1a5d8c271f351f8dc8679a68a969b0fe6c3cad62 (patch)
tree599c91c85fb465a3718129fc7866ba73263f5cff /target/linux/ramips/image
parent28a7ad2f506a4bb3b736b7a74eafebe12d67bb72 (diff)
downloadmaster-187ad058-1a5d8c271f351f8dc8679a68a969b0fe6c3cad62.tar.gz
master-187ad058-1a5d8c271f351f8dc8679a68a969b0fe6c3cad62.tar.bz2
master-187ad058-1a5d8c271f351f8dc8679a68a969b0fe6c3cad62.zip
ralink: add support for netis WF-2881
netis WF-2881 is an MT7621AT based router with MT7602EN, MT7612EN. It has 128MB DDR3, 128MB SLC NAND FLASH, 5-port Gbps switch and 1x USB 3.0. The following patch adds support for this device. this device only works on top of UBI. Tested and working: * ethernet * both WiFi radios * USB 3.0 * buttons (reset button) * ethernet switch and USB diag LEDs * UART * GPIOs * sysupgrade Tested and not working * failsafe Signed-off-by: YounJae Rho <luxflow@live.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47619 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 5a2b98cac6..9521f2cfd0 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -954,7 +954,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
endif
define Device/mt7621
@@ -1009,6 +1009,15 @@ define Device/zbt-wg2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+define Device/wf-2881
+ DTS := WF-2881
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ KERNEL_SIZE := 2097152
+ FILESYSTEMS := squashfs
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+endef
+
#
# MT7628 Profiles
#