aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:40 +0000
commit7ffc163753c223adac197df992e3216fc927085a (patch)
tree1c335fa56ad3f2bdaeda5b44e4f31f549bf47753 /target/linux/ramips/image/Makefile
parent6c0382c4961356b5a4542adfe756c4cfea4d1f1d (diff)
downloadmaster-187ad058-7ffc163753c223adac197df992e3216fc927085a.tar.gz
master-187ad058-7ffc163753c223adac197df992e3216fc927085a.tar.bz2
master-187ad058-7ffc163753c223adac197df992e3216fc927085a.zip
ramips: rt305x: add initial support for Tenda W306R V2.0
More device info at: http://wiki.openwrt.org/toh/tenda/w306r Signed-off-by: David Pearce <David_18051985@hotmail.com.au> [juhosg: fix checkpatch errors, remove kmod-phy and luci-ssl packages from the profile, change broken GPIO number] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 0c37f7e352..aac9ad2ea3 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -371,6 +371,10 @@ define Image/Build/Profile/V22RW2X2
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,v22rw-2x2,V22RW-2X2,ttyS1,57600,phys)
endef
+define Image/Build/Profile/W306R_V20
+ $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,w306r-v20,W306R_V20,ttyS1,57600,phys)
+endef
+
define Image/Build/Profile/W502U
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,w502u,W502U,ttyS1,115200,phys)
endef
@@ -428,6 +432,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/RTG32B1,$(1))
$(call Image/Build/Profile/SLR7205,$(1))
$(call Image/Build/Profile/V22RW2X2,$(1))
+ $(call Image/Build/Profile/W306R_V20,$(1))
$(call Image/Build/Profile/W502U,$(1))
$(call Image/Build/Profile/WCR150GN,$(1))
$(call Image/Build/Profile/WHRG300N,$(1))