aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:13 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-11 15:04:13 +0000
commit530b8f83d77b21855520fc08266ed29b74efc893 (patch)
tree2e2594371a080d9b2a3c35926bfc4141bfa4a8a2 /target/linux/ramips/image/Makefile
parent0065f15e56d28a20eb9d1de1ccb446fe3093b822 (diff)
downloadmaster-187ad058-530b8f83d77b21855520fc08266ed29b74efc893.tar.gz
master-187ad058-530b8f83d77b21855520fc08266ed29b74efc893.tar.bz2
master-187ad058-530b8f83d77b21855520fc08266ed29b74efc893.zip
ramips: add additional support for MQmaker WiTi board
The board is based on mt7621AT cpu, and has 16mb nor flash, 256mb of ram, 2 sata ports, microsd card slot, 1 USB 3.0 port and at least one 2.4 and one 5 ghz antenna. This is the 6th submission that adds support for XHCI in the device tree file, along with switching the location of the 2 radio's and addition of the kmod-i2c-mt7621 in the default packages of the profile. Signed-off-by: Sebastian Careba <nitroshift@yahoo.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47845 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 01e3fcbf11..63d6222223 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -954,7 +954,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626 wf-2881
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 witi wf-2881 zbt-wg2626
endif
define Device/mt7621
@@ -1004,6 +1004,11 @@ define Device/sap-g3200u3
DTS := SAP-G3200U3
endef
+define Device/witi
+ DTS := WITI
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)