aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-29 17:37:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-29 17:37:14 +0000
commit3728865f2715a722c6d3ca26aa5bb3078086d082 (patch)
tree5d6d0ce0d89665b4033ae42085924417dd92570f /target/linux/ramips/image/Makefile
parent0d59d58665d3ec1bb7f03851433b5b1d4107be37 (diff)
downloadmaster-187ad058-3728865f2715a722c6d3ca26aa5bb3078086d082.tar.gz
master-187ad058-3728865f2715a722c6d3ca26aa5bb3078086d082.tar.bz2
master-187ad058-3728865f2715a722c6d3ca26aa5bb3078086d082.zip
ramips: rt305x: add profile and build image for the Asus RT-N13U
Signed-off-by: Amit Mendapara <mendapara.amit@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34407 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 6509e2deaf..20df6e451b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -259,6 +259,10 @@ define BuildFirmware/FONERA20N/initramfs
$(call BuildFirmware/GENERIC_8M/initramfs,$(1),fonera20n,FONERA20N,ttyS1,57600,phys)
endef
+define BuildFirmware/RT-N13U
+ $(call BuildFirmware/GENERIC_8M,$(1),rt-n13u,RT-N13U,ttyS1,57600,phys)
+endef
+
mtdlayout_nw718=192k(u-boot)ro,128k(config)ro,64k(factory)ro,896k(kernel),2816k(rootfs),3712k@0x60000(firmware)
kernel_size_nw718=917504
rootfs_size_nw718=2883584
@@ -493,6 +497,10 @@ define Image/Build/Profile/FONERA20N
$(call Image/Build/Template/$(fs_squash)/$(1),FONERA20N)
endef
+define Image/Build/Profile/RT-N13U
+ $(call Image/Build/Template/$(fs_squash)/$(1),RT-N13U)
+endef
+
define Image/Build/Profile/FREESTATION5
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,freestation5,FREESTATION5,ttyS1,115200,phys)
endef
@@ -604,6 +612,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/F5D8235V2,$(1))
$(call Image/Build/Profile/RTN10PLUS,$(1))
$(call Image/Build/Profile/FONERA20N,$(1))
+ $(call Image/Build/Profile/RT-N13U,$(1))
$(call Image/Build/Profile/FREESTATION5,$(1))
$(call Image/Build/Profile/HW5503G,$(1))
$(call Image/Build/Profile/MOFI35003GN,$(1))