aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:44 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:44 +0000
commit13b3613164d833f8bd3f0b0140f24b789043b477 (patch)
tree8ddabf0e3e10143b9bc76b101f7869910ce2d0d4 /target/linux/ramips/image/Makefile
parentd36fd45d78bc3189d5ed73388a8fe4a036b5b334 (diff)
downloadmaster-187ad058-13b3613164d833f8bd3f0b0140f24b789043b477.tar.gz
master-187ad058-13b3613164d833f8bd3f0b0140f24b789043b477.tar.bz2
master-187ad058-13b3613164d833f8bd3f0b0140f24b789043b477.zip
ramips: rt3883: add profile and build sysupgrade image for the RT-N56U
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31399 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d310d26032..1330fa318b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -449,6 +449,19 @@ define Image/Build/Profile/Default
endef
endif
+#
+# RT3662/RT3883 Profiles
+#
+define Image/Build/Profile/RTN56U
+ $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,rt-n56u,RT-N56U,ttyS1,57600,phys)
+endef
+
+ifeq ($(CONFIG_RALINK_RT3883),y)
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/RTN56U,$(1))
+endef
+endif
+
define Image/Build/Initramfs
$(call Image/Build/Profile/$(PROFILE),initramfs)
endef