aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-01-06 11:11:42 +0000
committerJohn Crispin <blogic@openwrt.org>2013-01-06 11:11:42 +0000
commitbadcf6990835a49caede0c795d524345ccb43372 (patch)
tree3738a1d314d3341d30961145a8cd3639bcb447bd /target/linux/ramips/files
parent23f058aa9d0fea242c52199f618e15526eff3e29 (diff)
downloadmaster-187ad058-badcf6990835a49caede0c795d524345ccb43372.tar.gz
master-187ad058-badcf6990835a49caede0c795d524345ccb43372.tar.bz2
master-187ad058-badcf6990835a49caede0c795d524345ccb43372.zip
[ramips] adds support for Edimax BR-6524N
fixes #12754 Signed-off-by: <rq@akl.lt> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35020 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/files')
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c74
4 files changed, 81 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index 3a750df01d..bc183ab6ab 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -15,6 +15,7 @@ enum ramips_mach_type {
RAMIPS_MACH_GENERIC,
/* RT2880 based machines */
RAMIPS_MACH_F5D8235_V1, /* Belkin F5D8235 v1 */
+ RAMIPS_MACH_BR6524N, /* Edimax BR6524N */
RAMIPS_MACH_RT_N15, /* Asus RT-N15 */
RAMIPS_MACH_V11ST_FE, /* Ralink V11ST-FE */
RAMIPS_MACH_WLI_TX4_AG300N, /* Buffalo WLI-TX4-AG300N */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
index 31dcc8132b..739561c640 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
@@ -6,6 +6,11 @@ config RT288X_MACH_F5D8235_V1
bool "Belkin F5D8235 V1 board support"
select RALINK_DEV_GPIO_LEDS
+config RT288X_MACH_BR6524N
+ bool "Edimax BR6524N support"
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
config RT288X_MACH_RT_N15
bool "Asus RT-N15 board support"
select RALINK_DEV_GPIO_BUTTONS
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
index 473f855998..eb60c5d10d 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
@@ -14,6 +14,7 @@ obj-y := irq.o setup.o rt288x.o devices.o clock.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
obj-$(CONFIG_RT288X_MACH_F5D8235_V1) += mach-f5d8235-v1.o
+obj-$(CONFIG_RT288X_MACH_BR6524N) += mach-br6524n.o
obj-$(CONFIG_RT288X_MACH_RT_N15) += mach-rt-n15.o
obj-$(CONFIG_RT288X_MACH_V11ST_FE) += mach-v11st-fe.o
obj-$(CONFIG_RT288X_MACH_WLI_TX4_AG300N) += mach-wli-tx4-ag300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c
new file mode 100644
index 0000000000..ff4746cda5
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-br6524n.c
@@ -0,0 +1,74 @@
+/*
+ * Edimax BR6524N board support
+ *
+ * Copyright (C) 2012 Florian Fainelli <florian@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ethtool.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_regs.h>
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#include "devices.h"
+
+#define BR6524N_GPIO_STATUS_LED 12
+#define BR6524N_GPIO_BUTTON_WPS 0
+
+#define BR6524N_KEYS_POLL_INTERVAL 20
+#define BR6524N_KEYS_DEBOUNCE_INTERVAL (3 * BR6524N_KEYS_POLL_INTERVAL)
+
+static struct gpio_led br6524n_leds_gpio[] __initdata = {
+ {
+ .name = "br6524n:green:status",
+ .gpio = BR6524N_GPIO_STATUS_LED,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button br6524n_gpio_buttons[] __initdata = {
+ {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = BR6524N_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = BR6524N_GPIO_BUTTON_WPS,
+ }
+};
+
+static void __init br6524n_fe_init(void)
+{
+ rt288x_gpio_init(RT2880_GPIO_MODE_UART0);
+
+ rt288x_register_flash(0);
+
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(br6524n_leds_gpio),
+ br6524n_leds_gpio);
+
+ ramips_register_gpio_buttons(-1, BR6524N_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(br6524n_gpio_buttons),
+ br6524n_gpio_buttons);
+
+ rt288x_register_wifi();
+
+ /* Board is connected to an IC+ IP175C Fast Ethernet switch */
+ rt288x_eth_data.speed = SPEED_100;
+ rt288x_eth_data.duplex = DUPLEX_FULL;
+ rt288x_eth_data.tx_fc = 1;
+ rt288x_eth_data.rx_fc = 1;
+ rt288x_eth_data.phy_mask = BIT(0);
+ rt288x_register_ethernet();
+
+ rt288x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_BR6524N, "BR6524N", "Edimax BR6524N", br6524n_fe_init);