aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-06 09:31:03 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-06 09:31:03 +0000
commitc4a31fe958065654c5c24352fc53abb54895de9f (patch)
tree6e629d58d58bc6c48d22621dca5a42927f836c62 /target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
parentca1c7e3a82cfb33e5f4c35a17d6fa3262ce679d4 (diff)
downloadmaster-187ad058-c4a31fe958065654c5c24352fc53abb54895de9f.tar.gz
master-187ad058-c4a31fe958065654c5c24352fc53abb54895de9f.tar.bz2
master-187ad058-c4a31fe958065654c5c24352fc53abb54895de9f.zip
ralink: move ethernet driver to files/
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43194 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile')
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
new file mode 100644
index 0000000000..01884a7836
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
@@ -0,0 +1,18 @@
+#
+# Makefile for the Ralink SoCs built-in ethernet macs
+#
+
+ralink-eth-y += ralink_soc_eth.o ralink_ethtool.o
+
+ralink-eth-$(CONFIG_NET_RALINK_MDIO) += mdio.o
+ralink-eth-$(CONFIG_NET_RALINK_MDIO_RT2880) += mdio_rt2880.o
+
+ralink-eth-$(CONFIG_NET_RALINK_ESW_RT3052) += esw_rt3052.o
+ralink-eth-$(CONFIG_NET_RALINK_GSW_MT7620) += gsw_mt7620a.o mt7530.o
+
+ralink-eth-$(CONFIG_SOC_RT288X) += soc_rt2880.o
+ralink-eth-$(CONFIG_SOC_RT305X) += soc_rt305x.o
+ralink-eth-$(CONFIG_SOC_RT3883) += soc_rt3883.o
+ralink-eth-$(CONFIG_SOC_MT7620) += soc_mt7620.o
+
+obj-$(CONFIG_NET_RALINK) += ralink-eth.o