aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-04-03 09:58:44 +0000
committerJohn Crispin <blogic@openwrt.org>2013-04-03 09:58:44 +0000
commit84238ad24d5bdf6b95cc3d972908d699502764ab (patch)
tree6438279d1866fffb0c66b568f2ee3e64f2aa89b0 /target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
parentfd1af44d07b5c0eccd58bf24805810d2f0077936 (diff)
downloadmaster-187ad058-84238ad24d5bdf6b95cc3d972908d699502764ab.tar.gz
master-187ad058-84238ad24d5bdf6b95cc3d972908d699502764ab.tar.bz2
master-187ad058-84238ad24d5bdf6b95cc3d972908d699502764ab.zip
[ramips] move files to files-3.7
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36161 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile')
-rw-r--r--target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile b/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
new file mode 100644
index 0000000000..95c5b66fea
--- /dev/null
+++ b/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
@@ -0,0 +1,25 @@
+#
+# Makefile for DWC_otg Highspeed USB controller driver
+#
+
+ifeq ($(CONFIG_DWC_OTG_DEBUG),y)
+EXTRA_CFLAGS += -DDEBUG
+endif
+
+# Use one of the following flags to compile the software in host-only or
+# device-only mode.
+ifeq ($(CONFIG_DWC_OTG_HOST_ONLY),y)
+EXTRA_CFLAGS += -DDWC_HOST_ONLY
+EXTRA_CFLAGS += -DDWC_EN_ISOC
+endif
+
+ifeq ($(CONFIG_DWC_OTG_DEVICE_ONLY),y)
+EXTRA_CFLAGS += -DDWC_DEVICE_ONLY
+endif
+
+obj-$(CONFIG_DWC_OTG) := dwc_otg.o
+
+dwc_otg-objs := dwc_otg_driver.o dwc_otg_attr.o
+dwc_otg-objs += dwc_otg_cil.o dwc_otg_cil_intr.o
+dwc_otg-objs += dwc_otg_pcd.o dwc_otg_pcd_intr.o
+dwc_otg-objs += dwc_otg_hcd.o dwc_otg_hcd_intr.o dwc_otg_hcd_queue.o